Home > All, Citrix, Provisioning Services, XenServer > HEADS UP – PVS and XenServer compatibility issues

HEADS UP – PVS and XenServer compatibility issues

UPDATE!!! SEE THIS POST FOR MORE INFORMATION AND PVS SUPPORT ON XENSERVER 6.1; http://richardegenas.com/2013/01/22/pvs-support-in-xenserver-6-1-via-_poppelgaard-xenserver-citrix-pvs/ 

Ok, this is something that many may be aware of but I’m sure not all of you out there! Thanks Per Liif for the inputs to this little blog post!!

So what’s the issue? Well you can summarize it by saying that XenServer 6.1 and PVS is not compliant out of the box!

The Citrix information about this issue can be found here and basically tells you that; The standard XenServer Tools do not include support for Volume Shadow Copy Service (VSS) or Citrix Provisioning Services (PVS). For customers who wish to use VSS or PVS, the legacy XenServer Tools must be used.

What does this then mean in real life if you go ahead and use the standard XenServer tools and what errors might you be struggling with if you have this issue? Answer; you’ll see blue screens like this (xenvif.sys);

So what shall you do to prevent this, well use the steps in the support article from Citrix PRIOR to installing the legacy tools (xenlegacy.exe), otherwise you’ll end up with this blue screen (xenvbd.sys);

And of course you could argue whether Citrix could have provided a bit more heads up for everyone out there in the release notes and blog posts of XenServer 6.1. I hope that not many of you ran into this and spent to much time on it prior to finding the Citrix workaround article!

//Richard

  1. Henry
    October 10, 2012 at 09:38

    Hi Richard,

    I also got this problem, am testing it on my beta network PVS6.1 & XS6.1 and XenDesktop / XenApp…

    The really frustrating bit is that you have to do this for all you vm’s… lets say 20 XenDesktop machines.. 20 times the adjustement on the console otherwise BSOD.. jeez…

  2. November 13, 2012 at 11:19

    Hi Henry, XenServer 6.1 doesn’t support XenDesktop at all ! http://support.citrix.com/article/CTX131239

  3. Chris
    January 31, 2013 at 16:59

    Where is the link to the Citrix article. The blog post is exactly the problem I have, but I cannot find the CTX article.

  4. January 31, 2013 at 17:17

    Hi Chris, have a look at this post; https://richardegenas.com/2013/01/22/pvs-support-in-xenserver-6-1-via-_poppelgaard-xenserver-citrix-pvs/ That should point you in the right direction. Cheers! //Richard

  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: